
<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="https://gmpg.org/xfn/11">

	
			
	<!-- Cookies Consent Notice start -->
	<script src="https://ccpa-script.psg.nexstardigital.net/site/rochesterfirst"></script> 	<!-- Cookies Consent Notice end -->
	
			<script type="text/javascript" src="https://www.rochesterfirst.com/wp-content/plugins/universal-data-layer/js/udl.js?ver=1.0.4"></script>
		<script>
			window.NXSTdata.content = Object.assign( window.NXSTdata.content, {"title":"Careers hang on mail-in ballots for 2 House Democrats | RochesterFirst","homepageTitle":"","socialTitle":"","pageType":"article","authorName":"KAREN MATTHEWS, Associated Press","description":"NEW YORK (AP) \u2014 New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted \u2014 a process that begins Wednesday \u2014 to learn whether they will serve an additional term. Voting in New York&#8217;s primary election [&hellip;]","publicationDate":"2020-06-30T09:37:16-04:00","lastModifiedDate":"2020-06-30T09:37:16-04:00","publicationDayOfWeek":"Tuesday","categoryList":["Politics"],"primaryCategory":"Politics","tagList":[],"wordCount":695,"paragraphCount":21,"imageCount":0,"videoCount":0,"slideshowCount":0,"pageId":464337,"isShared":false,"originalSource":"","sharingMode":"","primaryCategoryId":70} )
			window.NXSTdata.page = Object.assign( window.NXSTdata.page, {"canonicalUrl":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/","ampUrl":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/amp\/","urlHostname":"https:\/\/www.rochesterfirst.com","urlSlug":"careers-hang-on-mail-in-ballots-for-2-house-democrats","directoryPath":["news","politics"]} )
			window.NXSTdata.site = Object.assign( window.NXSTdata.site, {"brandName":"RochesterFirst","callSign":"WROC","domainName":"www.rochesterfirst.com","timeZone":"America\/New_York","segmentKey":""} )
			window.NXSTdata.ads = Object.assign( window.NXSTdata.ads, {"a9Enabled":true,"confiantEnabled":true,"indexExchangeEnabled":true,"nativoEnabled":false,"revContentEnabled":false,"prebidEnabled":false} )
		</script>
		
						<script src="https://cdn.blueconic.net/nexstar.js"></script>
	
	
<!-- BoB -->
<script async type="text/javascript" id="bob_tag_loader">
var page_url = "https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/" || "";
var cats = "Politics" || "";
var bob_kw = "" || "";
var bob_desc = "NEW YORK (AP) \u2014 New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted \u2014 a process that begins Wednesday \u2014 to learn whether they will serve an additional term. Voting in New York&#8217;s primary election [&hellip;]" || "";
var bob_story_author = "KAREN MATTHEWS, Associated Press" || "";
var cat_data = "&cats=" + encodeURIComponent(cats) + "&bob_kw=" + encodeURIComponent(bob_kw) + "&bob_desc=" + encodeURIComponent(bob_desc) + "&story_author=" + encodeURIComponent(bob_story_author) + "&page_url=" + encodeURIComponent(page_url);
var bob_base = "bob.dmpxs.com";

var bob_cb = '1';
bob_cb = ((new Date()).getTime() + "" + Math.floor(Math.random() * 1000000)).substr(0, 16);
(function () {
var bob_tag = document.createElement('script');
bob_tag.type = 'text/javascript';
bob_tag.async = true;
bob_tag.id = "bob_tag";
bob_tag.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + bob_base + '/static/bob_001.js?bob_cb=' + bob_cb + cat_data;
var bts = document.getElementsByTagName('script')[0];
bts.parentNode.insertBefore(bob_tag, bts);
})();
</script>



			
<!-- DEVCON -->
<script
	id="ns_script_dc"
	data-key="f0d16886-0300-4694-9b7b-37da481f4449"
	data-e="5"
	src="https://includemodal.global.ssl.fastly.net/sp.js"
	type="text/javascript"
	async
></script>
	
	
<!-- Prebid -->
<script>
	window.isPrebidEnabled = false;
</script>


				
<!-- Index Exchange -->
<script async src="https://js-sec.indexww.com/ht/p/184979-164251977320883.js"></script> 	
	
<!-- A9 APS -->
<script>
	window.isApsEnabled = true;
</script>


<!-- A9 APS -->
<script type="text/javascript">
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({"pubID":"3410","adServer":"googletag"});
</script>

				
<!-- Confiant ad fraud protection -->
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/Y2Nn8JmiAY8HpnF4sl5n7J71jaI/gpt_and_prebid/config.js"></script> 	
	
<script type="text/javascript">
(function() {
	var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
	_sf_async_config.uid = "23192";
	_sf_async_config.domain = "rochesterfirst.com";
	_sf_async_config.flickerControl = false; 	_sf_async_config.useCanonical = true;
	_sf_async_config.useCanonicalDomain = true;
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>

	
<!-- Google Publisher Tag -->
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<!-- End Google Publisher Tag -->


	
<!-- Google Tag Manager dataLayer -->
<script>
var dataLayer = window.dataLayer = window.dataLayer || [];
dataLayer.push({"fireGTM":true,"propID":"UA-37144901-8","event":"dlReady","paragraphCount":21,"wordCount":695,"authorName":"KAREN MATTHEWS, Associated Press","imageCount":0,"siteName":"RochesterFirst","publishDateString":"Tue Jun 30 2020","publishTimeString":"09:37 AM EDT","originalContent":false,"classifyText":[],"categories":"Politics","primaryCategory":"Politics","topics":""});
</script>
<!-- End Google Tag Manager dataLayer  -->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',"GTM-KJJZHXD");</script>
<!-- End Google Tag Manager -->
	
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',"GTM-MSL4CH");</script>
<!-- End Google Tag Manager -->
	
	
	
	
	<script type="application/ld+json">
	{"@context":"https:\/\/schema.org","@type":"NewsArticle","publisher":{"@type":"Organization","name":"RochesterFirst","logo":{"@type":"ImageObject","url":"https:\/\/www.rochesterfirst.com\/wp-content\/uploads\/sites\/66\/2019\/06\/cropped-Rochester-First_Logo-copy.png"}},"name":"RochesterFirst","description":"NEW YORK (AP) \u2014 New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted \u2014 a process that begins Wednesday \u2014 to learn whether they will serve an additional term. Voting in New York&#8217;s primary election [&hellip;]","headline":"Careers hang on mail-in ballots for 2 House Democrats","datePublished":"2020-06-30T13:37:16+00:00","dateModified":"2020-06-30T13:37:16+00:00","url":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/","author":[{"@type":"Person","name":"KAREN MATTHEWS, Associated Press"}],"image":{"@type":"ImageObject","url":"https:\/\/www.rochesterfirst.com\/wp-content\/uploads\/sites\/66\/2019\/06\/cropped-Rochester-First_Logo-copy.png"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/"},"articleSection":"Politics","genre":["Politics"]}</script>

	<title>Careers hang on mail-in ballots for 2 House Democrats | RochesterFirst</title>
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RochesterFirst &raquo; Feed" href="https://www.rochesterfirst.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RochesterFirst &raquo; Comments Feed" href="https://www.rochesterfirst.com/comments/feed/" />
<script class="wp-asset-manager page_attributes" type="text/javascript">window.amScripts = window.amScripts || {}; window.amScripts["page_attributes"] = {"page_url":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/","page_slug":"careers-hang-on-mail-in-ballots-for-2-house-democrats","page_type":"story","page_category":"politics","article_id":464337,"subpath":"\/news\/politics"}</script><script class="wp-asset-manager gpt" type="text/javascript">window.amScripts = window.amScripts || {}; window.amScripts["gpt"] = {"ab_test":{"min":1,"max":101,"storage_key":"ns.gpt.sessiontest"}}</script><script class="wp-asset-manager bob" type="text/javascript">window.amScripts = window.amScripts || {}; window.amScripts["bob"] = {"base_host":"bob.dmpxs.com"}</script><script class="wp-asset-manager ns-ad-loader-js" type="text/javascript">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</script><meta name='description' content='NEW YORK (AP) — New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted — a process that begins Wednesday — to learn whether they will serve an additional term. Voting in New York&#8217;s primary election [&hellip;]' /><!-- WP SEO -->
<meta name='google-site-verification' content='RzQ6nZWgJ7BQT1FNNgkuODWDPzedsFUDw3kr1p6Ljv0' /><!-- WP SEO -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rochesterfirst.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style>
	:root {
		--primary_color: #1153C3;
		--alert_banner_label_sep: '/';
		--image_width_thumbnail: 150px;
		--image_width_medium: 300px;
		--image_width_large: 1280px;
	}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.rochesterfirst.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='ns-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%2C700i%7CRoboto+Condensed%3A400%2C700&#038;ver=1.0' media='all' />
<link rel='stylesheet' id='ns-global-css-css'  href='https://www.rochesterfirst.com/wp-content/themes/nexstar/client/build/css/global.min.css?ver=a9c3ea0f95a0739b4edd' media='all' />
<link rel='stylesheet' id='ns-article-css-css'  href='https://www.rochesterfirst.com/wp-content/themes/nexstar/client/build/css/article.min.css?ver=84fc139ad35aab5936a5' media='all' />
<style id='ns-article-css-inline-css'>
.article--is-condensed .article-content { max-height: 450px; }
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.rochesterfirst.com/wp-content/mu-plugins/jetpack/css/jetpack.css?ver=8.6.1' media='all' />
<script src='https://www.rochesterfirst.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://www.rochesterfirst.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.rochesterfirst.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rochesterfirst.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rochesterfirst.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://www.rochesterfirst.com/news/politics/careers-hang-on-mail-in-ballots-for-2-house-democrats/" />
<link rel='shortlink' href='https://www.rochesterfirst.com/?p=464337' />
<link rel="alternate" type="application/json+oembed" href="https://www.rochesterfirst.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rochesterfirst.com%2Fnews%2Fpolitics%2Fcareers-hang-on-mail-in-ballots-for-2-house-democrats%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rochesterfirst.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rochesterfirst.com%2Fnews%2Fpolitics%2Fcareers-hang-on-mail-in-ballots-for-2-house-democrats%2F&#038;format=xml" />
			<meta property="fb:pages" content="" />
			<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript" src=""></script><link rel="amphtml" href="https://www.rochesterfirst.com/news/politics/careers-hang-on-mail-in-ballots-for-2-house-democrats/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Careers hang on mail-in ballots for 2 House Democrats" />
<meta property="og:url" content="https://www.rochesterfirst.com/news/politics/careers-hang-on-mail-in-ballots-for-2-house-democrats/" />
<meta property="og:description" content="NEW YORK (AP) — New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted — a pr…" />
<meta property="article:published_time" content="2020-06-30T13:37:16+00:00" />
<meta property="article:modified_time" content="2020-06-30T13:37:16+00:00" />
<meta property="og:site_name" content="RochesterFirst" />
<meta property="og:image" content="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg" />
<meta property="og:image:width" content="512" />
<meta property="og:image:height" content="512" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Careers hang on mail-in ballots for 2 House Democrats" />
<meta name="twitter:image" content="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg?w=240" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Careers hang on mail-in ballots for 2 House Democrats" />
<meta name="twitter:description" content="NEW YORK (AP) — New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted — a pr…" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg?w=32" sizes="32x32" />
<link rel="icon" href="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg?w=180" />
<meta name="msapplication-TileImage" content="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Favicon_512x512-1.jpg?w=270" />
</head>

<body class="feed_post-template-default single single-feed_post postid-464337 wp-custom-logo nexstar has-active-alert-banners">
	
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KJJZHXD"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

	
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MSL4CH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

	<div id="page" class="site">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
	<div class="site-header__content">
					<p class="screen-reader-text"><a href="https://www.rochesterfirst.com/" rel="home">RochesterFirst</a></p>
		
		<div class="site-header__branding">
			<div class="site-header__branding__content">
				<div class="site-header__logo">
					<a href="https://www.rochesterfirst.com/" rel="home">
						<img src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Rochester-First_Logo-copy.png" alt="Politics" />
						<div class="site-header__logo-bg" style="background-image: url('https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Rochester-First_Logo-copy.png');"></div>
					</a>
				</div>
				<div class="site-header__weather">
											<a href="https://www.rochesterfirst.com/weather/">
							<span class="site-header__weather-region">Rochester</span>
							<span class="site-header__weather-forecast">
								<span class="site-header__weather-forecast__text">69&deg;</span>
								<figure class="site-header__weather-forecast__icon">
									<span class="weather-icon weather-icon-sm weather-icon-light-98"></span>
								</figure>
							</span>
						</a>
									</div>
				<div class="site-header__widget">
					<div class="site-header__sponsor">
						<aside class="ad-unit ad-unit--microbar ad-unit--microbar--header">
															<span class="ad_unit__label">Sponsored By</span>
														<div class="ad-unit__content">
								  <div   id="acm-ad-tag-header-microbar-header-microbar"   data-slot='{"pos":"header-microbar","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[88,31],"sizes":[[[900,0],[[88,31]]],[[0,0],[]]],"amp_multi_size":"88x31","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"header-microbar","tag_id":"header-microbar","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"header-microbar","fold":"atf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-header-microbar-header-microbar'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  							</div>
						</aside>

					</div>
					<button class="site-header__toggle" aria-controls="supernav" aria-expanded="false">
						<span class="screen-reader-text">Toggle Menu</span>
						<span class="icon icon--navicon">
							
<svg aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 19.969 12.063">
	<title>Open Navigation</title>
	<path fill="#fff" d="M.793 1.556h18.363a.778.778 0 1 0 0-1.555H.793a.854.854 0 0 0-.809.778.73.73 0 0 0 .809.777zm18.363 3.695H.793a.778.778 0 1 0 0 1.555h18.363a.778.778 0 1 0 0-1.555zm0 5.25H.793a.779.779 0 1 0 0 1.556h18.363a.779.779 0 1 0 0-1.557z" />
</svg>
						</span>
						<span class="icon icon--close">
							
<svg aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16.85 16.875">
	<title>Close Navigation</title>
	<path fill="#fff" d="M9.65 8.454l6.88-7.063a.809.809 0 0 0 0-1.15.782.782 0 0 0-1.14 0L8.52 7.305 1.37.241a.782.782 0 0 0-1.14 0 .809.809 0 0 0 0 1.15l7.15 7.063-7.15 7.063a.809.809 0 0 0 0 1.15.824.824 0 0 0 .6.219.787.787 0 0 0 .59-.219l7.15-7.063 6.87 7.063a.824.824 0 0 0 .6.219.619.619 0 0 0 .54-.219.792.792 0 0 0 0-1.15z" />
</svg>
						</span>
					</button>
				</div>
			</div>
		</div>

		<nav id="siteNavigation" class="site-header__navigation">
			<div class="site-header__search-full">
				
<form role="search" class="search-form site-header__search-form" action="https://www.rochesterfirst.com/">
	<span class="screen-reader-text">Search</span>
	<div class="search-form__fields">
		<input type="search" name="s" placeholder="Site Search..." />
		<input type="submit" name="submit" value="" />
			</div>

	</form>
			</div>

			<div class="site-header__navigation__content">
				<h2 class="screen-reader-text">Primary Menu</h2>


				<ul id="supernav" class="menu">
	<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-articles menu-item-109"><a href="https://www.rochesterfirst.com/news/">News</a>
<div class="dropnav dropnav--4-col dropnav--full-width">
	<div class="dropnav__section dropnav__section--sub-menu dropnav__section--half">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-4294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4294"><a href="https://www.rochesterfirst.com/news/local-news/">Local News</a></li>
	<li id="menu-item-152657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152657"><a href="https://www.rochesterfirst.com/news/state-news/">New York State News</a></li>
	<li id="menu-item-4295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4295"><a href="https://www.rochesterfirst.com/news/national-news/">National News</a></li>
	<li id="menu-item-167283" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-167283"><a href="https://www.rochesterfirst.com/news/international/">International News</a></li>
	<li id="menu-item-222851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222851"><a href="https://www.rochesterfirst.com/washington/">Washington</a></li>
	<li id="menu-item-8126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8126"><a href="https://www.rochesterfirst.com/news/business/">Business News</a></li>
	<li id="menu-item-330669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330669"><a href="https://www.rochesterfirst.com/coronavirus/">Coronavirus</a></li>
	<li id="menu-item-152659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152659"><a href="https://www.rochesterfirst.com/news/your-local-election-hq/">Your Local Election HQ</a></li>
	<li id="menu-item-8128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8128"><a href="https://www.rochesterfirst.com/adam-interviews/">Adam Interviews</a></li>
	<li id="menu-item-75855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75855"><a href="https://www.rochesterfirst.com/archives/">News 8 Archives</a></li>
	<li id="menu-item-152660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152660"><a href="https://www.rochesterfirst.com/crime/">Crime</a></li>
	<li id="menu-item-152658" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152658"><a href="https://www.rochesterfirst.com/news/education/">Education</a></li>
	<li id="menu-item-451439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451439"><a href="https://www.rochesterfirst.com/newsfeed-now/">Newsfeed Now</a></li>
	<li id="menu-item-179468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-179468"><a href="https://www.rochesterfirst.com/news/digital-exclusives/">Digital Exclusives</a></li>
</ul>
</div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--top-story"><h3 class="article-list__heading">Top Stories</h3><div class="article-list__content"><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/businesswoman-upsets-5-term-congressman-in-colorado-primary/"
									>
			
				Businesswoman upsets 5-term congressman in Colorado primary
							</a>
					</h4>
	
	
	
	
	</div>

</article></div></div></div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--bulleted"><h3 class="article-list__heading article-list__heading--hidden">Top Stories</h3><div class="article-list__content"><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/courageous-conversations-on-race-for-the-monroe-county-sheriffs-office/"
									>
			
				&#8220;Courageous conversations&#8221; on race for the Monroe County Sheriff&#8217;s Office
							</a>
					</h4>
	
	
	
	
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/woman-25-in-critical-condition-after-riding-on-vehicles-roof/"
									>
			
				Woman, 25, in critical condition after riding on vehicle roof
							</a>
					</h4>
	
	
	
	
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/john-hickenlooper-wins-colorados-democratic-senate-primary/"
									>
			
				John Hickenlooper wins Colorado&#8217;s Democratic Senate primary
							</a>
					</h4>
	
	
	
	
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
									>
			
				Weather forecast: Hello, July!
							</a>
					</h4>
	
	
	
	
	</div>

</article></div></div></div></div></li>
<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-129"><a href="https://www.rochesterfirst.com/weather/">Weather</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-134116" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134116"><a href="https://www.rochesterfirst.com/weather/">Weather</a></li>
	<li id="menu-item-160948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-160948"><a href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/">Today&#8217;s Forecast</a></li>
	<li id="menu-item-175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-175"><a href="https://www.rochesterfirst.com/forecast/">8-Day Forecast</a></li>
	<li id="menu-item-168704" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-168704"><a href="https://www.rochesterfirst.com/weather/hourly-forecast/">Hourly Forecast</a></li>
	<li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://www.rochesterfirst.com/interactive-radar/">Interactive Radar</a></li>
	<li id="menu-item-7121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7121"><a href="https://www.rochesterfirst.com/weather-cameras/">Weather Cameras</a></li>
	<li id="menu-item-230871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230871"><a href="/weather/closings">Closings and Delays</a></li>
	<li id="menu-item-347759" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-347759"><a href="https://www.rochesterfirst.com/weather-blog/">Weather Blog</a></li>
	<li id="menu-item-410692" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-410692"><a href="https://www.rochesterfirst.com/weather-glossary/">Weather Glossary</a></li>
	<li id="menu-item-410691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-410691"><a href="https://www.rochesterfirst.com/weather-workshops/">Weather Workshops</a></li>
	<li id="menu-item-171295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171295"><a href="https://www.rochesterfirst.com/weather/weekend-forecast/">Weekend Forecast</a></li>
	<li id="menu-item-300" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300"><a href="https://www.rochesterfirst.com/weather-watchers/">Weather Watchers</a></li>
	<li id="menu-item-304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-304"><a href="https://www.rochesterfirst.com/map-center/">Map Center</a></li>
	<li id="menu-item-299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-299"><a href="https://www.rochesterfirst.com/traffic/">Traffic</a></li>
</ul>
</div></div></li>
<li id="menu-item-177954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-articles menu-item-177954"><a href="https://www.rochesterfirst.com/sports/local-sports/">Sports</a>
<div class="dropnav dropnav--4-col dropnav--full-width">
	<div class="dropnav__section dropnav__section--sub-menu dropnav__section--half">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-433677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-433677"><a href="https://www.rochesterfirst.com/home-hoops-tournament/">Home Hoops Tournament</a></li>
	<li id="menu-item-268405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-268405"><a href="https://www.rochesterfirst.com/sports/local-sports/">Local Sports</a></li>
	<li id="menu-item-4299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4299"><a href="https://www.rochesterfirst.com/sports/">National Sports</a></li>
	<li id="menu-item-75857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75857"><a href="https://www.rochesterfirst.com/rochestersports/">Rochester Pro Teams</a></li>
	<li id="menu-item-75856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75856"><a href="https://www.rochesterfirst.com/buffalobills/">The Bills Report</a></li>
	<li id="menu-item-4297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4297"><a href="https://www.rochesterfirst.com/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-276426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276426"><a href="https://www.rochesterfirst.com/sports/college-sports/">College Sports</a></li>
	<li id="menu-item-295649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-295649"><a href="https://www.rochesterfirst.com/section-v-best/">Section V Best</a></li>
	<li id="menu-item-75859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75859"><a href="https://www.rochesterfirst.com/sports/orange-nation/">Orange Nation</a></li>
	<li id="menu-item-75858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75858"><a href="https://www.rochesterfirst.com/every-team-has-a-story/">Every Team Has A Story</a></li>
	<li id="menu-item-220559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220559"><a href="https://www.rochesterfirst.com/western-ny-pga-tips/">Western NY PGA Tips</a></li>
	<li id="menu-item-238958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238958"><a href="https://www.rochesterfirst.com/sports/sports-video/">Sports Video</a></li>
	<li id="menu-item-396968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-396968"><a href="https://www.rochesterfirst.com/nfl/nfl-draft/">NFL Draft</a></li>
</ul>
</div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--top-story"><h3 class="article-list__heading">Top Stories</h3><div class="article-list__content"><article class="article-list__article article-list__article--is-stacked article-list__article--has-thumb">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/red-wings/minor-league-baseball-officially-cancels-2020-season/"
									>
			
				Minor League Baseball officially cancels 2020 season, 1st summer since 1898 with no baseball in Rochester
							</a>
					</h4>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/sports/red-wings/minor-league-baseball-officially-cancels-2020-season/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://i2.wp.com/www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=2000&#038;ssl=1"
		alt=""
		srcset=""
		sizes=""
	/>
</div>

					</div>

					</a>
			</figure>
	</article></div></div></div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--bulleted"><h3 class="article-list__heading article-list__heading--hidden">Top Stories</h3><div class="article-list__content"><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/local-sports/webster-wiffle-ball-league-has-big-league-feel/"
									>
			
				Webster wiffle ball league has big-league feel
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/the-bills-report/will-newton-swing-afc-east-title-away-from-buffalo/"
									>
			
				Will Newton swing AFC East title away from Buffalo?
							</a>
					</h4>
	
	
	
	
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/local-sports/local-nba-draft-prospects-to-host-dont-shut-up-and-dribble/"
									>
			
				Local NBA Draft prospects to host &#8216;Don&#8217;t Shut Up and Dribble&#8217; event
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/local-sports/sports-school-rit-head-coach-wayne-wilson-explains-offside/"
									>
			
				Sports School: RIT head coach Wayne Wilson explains offside
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article></div></div></div></div></li>
<li id="menu-item-131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-articles menu-item-131"><a href="https://www.rochesterfirst.com/video/">Video Center</a>
<div class="dropnav dropnav--4-col dropnav--full-width">
	<div class="dropnav__section dropnav__section--sub-menu dropnav__section--quarter">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-156977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-156977"><a href="https://www.rochesterfirst.com/video/">All Video</a></li>
	<li id="menu-item-267425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267425"><a href="https://www.rochesterfirst.com/sports-video/">Sports Video</a></li>
	<li id="menu-item-156978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156978"><a href="https://www.rochesterfirst.com/live/">Live</a></li>
	<li id="menu-item-9048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9048"><a href="https://www.rochesterfirst.com/cbsn-live/">CBSN Live</a></li>
	<li id="menu-item-267455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267455"><a href="https://www.rochesterfirst.com/kucko-camera/">Kucko&#8217;s Camera</a></li>
	<li id="menu-item-406913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-406913"><a href="https://www.rochesterfirst.com/news-8-specials/">News 8 Specials</a></li>
</ul>
</div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--top-story"><h3 class="article-list__heading">Top Stories</h3><div class="article-list__content"><article class="article-list__article article-list__article--is-stacked article-list__article--has-thumb">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
									>
			
				Weather forecast: Hello, July!
							</a>
					</h4>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://i2.wp.com/www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=2000&#038;ssl=1"
		alt=""
		srcset=""
		sizes=""
	/>
</div>

					</div>

					</a>
			</figure>
	</article></div></div></div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--top-story"><h3 class="article-list__heading article-list__heading--hidden">Top Stories</h3><div class="article-list__content"><article class="article-list__article article-list__article--is-stacked article-list__article--has-thumb">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/crime/police-looking-for-suspects-after-shooting-on-citys-northeast-side/"
									>
			
				Police looking for suspects after shooting on city&#8217;s northeast side
							</a>
					</h4>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/crime/police-looking-for-suspects-after-shooting-on-citys-northeast-side/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://i1.wp.com/www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=2000&#038;ssl=1"
		alt=""
		srcset=""
		sizes=""
	/>
</div>

					</div>

					</a>
			</figure>
	</article></div></div></div><div class="dropnav__section dropnav__section--article-list dropnav__section--quarter"><div class="article-list article-list--bulleted"><h3 class="article-list__heading article-list__heading--hidden">Top Stories</h3><div class="article-list__content"><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/gym-owners-working-with-state-leaders-regarding-opening-date/"
									>
			
				Gym owners working with state leaders regarding opening date
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/fairport-business-owners-welcoming-back-boaters-as-erie-canal-boat-traffic-reopens/"
									>
			
				Fairport business owners welcoming back boaters as Erie Canal boat traffic reopens
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/aaa-road-trips-will-make-up-97-of-summer-travel/"
									>
			
				AAA: Road trips will make up 97% of summer travel
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article><article class="article-list__article">
<div
	class="article-list__article-text"
	data-article-list-id=""
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[]"
>
			<h4 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/digital-exclusives/canandaigua-woman-arrested-trespassing-in-kangaroo-owners-backyard/"
									>
			
				Canandaigua woman arrested for trespassing in kangaroo owner&#8217;s backyard
							</a>
					</h4>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

</article></div></div></div></div></li>
<li id="menu-item-128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-128"><a href="/entertainment-news">Lifestyle</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-157006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157006"><a href="https://www.rochesterfirst.com/around-town/">Around Town</a></li>
	<li id="menu-item-8125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8125"><a href="https://www.rochesterfirst.com/entertainment-news/">Entertainment News</a></li>
	<li id="menu-item-6962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6962"><a href="https://www.rochesterfirst.com/news/health/">Health Watch</a></li>
	<li id="menu-item-315317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315317"><a href="https://www.rochesterfirst.com/news/tech-news/">Tech News</a></li>
	<li id="menu-item-75853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75853"><a href="https://www.rochesterfirst.com/news/recalls/">Recalls</a></li>
	<li id="menu-item-7119" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7119"><a href="https://www.rochesterfirst.com/gas-tracker/">Fuel Finder</a></li>
	<li id="menu-item-285671" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-285671"><a href="https://www.rochesterfirst.com/sunrise-smart-start/">Sunrise Smart Start</a></li>
	<li id="menu-item-204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-204"><a href="https://www.rochesterfirst.com/games/">Games</a></li>
	<li id="menu-item-315314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315314"><a href="https://www.rochesterfirst.com/lottery/">Lottery</a></li>
	<li id="menu-item-315315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315315"><a href="https://www.rochesterfirst.com/horoscope/">Horoscope</a></li>
	<li id="menu-item-156975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156975"><a href="https://www.rochesterfirst.com/home-improvement/">Home Improvement</a></li>
	<li id="menu-item-7117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7117"><a href="https://www.rochesterfirst.com/career-connection/">Career Connection</a></li>
	<li id="menu-item-455508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-455508"><a href="https://www.rochesterfirst.com/food-and-drink/">Food and Drink</a></li>
	<li id="menu-item-459903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-459903"><a href="https://www.rochesterfirst.com/destination-ny/">Destination NY</a></li>
</ul>
</div></div></li>
<li id="menu-item-142932" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-ancestor current-menu-parent current_page_parent current_page_ancestor menu-item-has-children menu-item-142932"><a href="https://www.rochesterfirst.com/community/">Community</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-143099" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143099"><a href="https://www.rochesterfirst.com/contests/">Contests</a></li>
	<li id="menu-item-142933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142933"><a href="https://www.rochesterfirst.com/community/">News 8 Events</a></li>
	<li id="menu-item-328" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-249 current_page_item menu-item-328"><a href="https://www.rochesterfirst.com/calendar/" aria-current="page">Calendar</a></li>
	<li id="menu-item-9071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9071"><a href="https://www.rochesterfirst.com/news-8-celebrates/">News 8 Celebrates</a></li>
	<li id="menu-item-407272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-407272"><a href="https://www.rochesterfirst.com/honor-roll-senior-salute/">Honor Roll: Senior Salute</a></li>
	<li id="menu-item-306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306"><a href="https://www.rochesterfirst.com/goldenappleaward/">Golden Apple Award</a></li>
	<li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="https://www.rochesterfirst.com/goldenapplescholarship/">Golden Apple Scholarship</a></li>
	<li id="menu-item-223163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-223163"><a href="https://www.rochesterfirst.com/putting-you-first/">Putting You First</a></li>
	<li id="menu-item-292522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-292522"><a href="https://www.rochesterfirst.com/why-roc/">Why ROC</a></li>
	<li id="menu-item-354981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354981"><a href="https://www.rochesterfirst.com/first-responders-spotlight/">First Responders Spotlight</a></li>
	<li id="menu-item-75854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75854"><a href="https://www.rochesterfirst.com/friend-for-life/">Friend For Life</a></li>
	<li id="menu-item-329" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-329"><a href="https://www.rochesterfirst.com/community-photos/">Community Photos</a></li>
	<li id="menu-item-390602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-390602"><a href="https://www.rochesterfirst.com/open-for-business/">Open For Business</a></li>
	<li id="menu-item-360925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-360925"><a href="https://www.rochesterfirst.com/puerto-rico-recovery/">Puerto Rico Recovery</a></li>
</ul>
</div></div></li>
<li id="menu-item-399945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-399945"><a href="https://www.rochesterfirst.com/report-it/">Report It!</a></li>
<li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-186"><a href="https://www.rochesterfirst.com/tv-schedule/">TV Schedule</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-419243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419243"><a href="https://www.rochesterfirst.com/tv-schedule/">TV Schedule</a></li>
	<li id="menu-item-419242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419242"><a href="https://www.rochesterfirst.com/community/program-interruptions/">Program Interruptions</a></li>
</ul>
</div></div></li>
<li id="menu-item-125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-125"><a href="https://www.rochesterfirst.com/about-us/">About Us</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-4293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4293"><a href="https://www.rochesterfirst.com/meet-the-team/">Meet The Team</a></li>
	<li id="menu-item-194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-194"><a href="https://www.rochesterfirst.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-193"><a href="https://www.rochesterfirst.com/advertise-with-us/">Advertise With Us</a></li>
	<li id="menu-item-135094" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135094"><a href="https://www.rochesterfirst.com/alexa/">Alexa</a></li>
	<li id="menu-item-7694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7694"><a href="https://www.rochesterfirst.com/email-alerts/">Email Alerts</a></li>
	<li id="menu-item-7695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7695"><a href="https://www.rochesterfirst.com/text-alerts/">Text Alerts</a></li>
	<li id="menu-item-197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-197"><a href="https://www.cbs.com/watch/">CBS Full Episodes</a></li>
	<li id="menu-item-187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-187"><a href="https://www.rochesterfirst.com/tv-schedule">TV Schedule</a></li>
	<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="https://www.rochesterfirst.com/careers/">Work For Us</a></li>
	<li id="menu-item-339213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-339213"><a href="#" data-component="NexstarCCPA">Do Not Sell My Personal Information</a></li>
</ul>
</div></div></li>
</ul>

				<div class="site-header__search-drop">
					<a class="site-header__search-drop__toggle" href="#">
						<span class="screen-reader-text">Search</span>
						<span class="icon">
							
<svg  aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 17">
	<title>Search</title>
	<path d="M15.72 15.4l-3.75-3.8a7 7 0 0 0 1.72-4.612 6.851 6.851 0 1 0-6.85 6.98 6.713 6.713 0 0 0 3.72-1.127l3.85 3.9a.9.9 0 0 0 .65.276.92.92 0 0 0 .66-.276.965.965 0 0 0 0-1.341zM1.85 6.984a4.991 4.991 0 1 1 4.99 5.087 5.036 5.036 0 0 1-4.99-5.09z" />
</svg>
						</span>
					</a>
					
<form role="search" class="search-form site-header__search-form" action="https://www.rochesterfirst.com/">
	<span class="screen-reader-text">Search</span>
	<div class="search-form__fields">
		<input type="search" name="s" placeholder="What are you looking for?" />
		<input type="submit" name="submit" value="Search" />
			</div>

	</form>
				</div>
			</div>
		</nav>
	</div>
</header>

		<div class="site-content-wrapper">
			
<div class="alert-banners js-alert-banners has-messages">
	
	<div
		class="alert-banner alert-banner--closings alert-banner--has-carousel"
		data-alert-banner-type="closings"
		data-component="alertBanner"	>
		<div class="alert-banner__inner">

			
<button class="alert-banner__prev-control js-alert-banner-prev">
	<span class="alert-banner__control-icon">
		<svg aria-hidden="true" tabindex="-1" viewBox="0 0 24 24"><path d="M15.41,16.58L10.83,12L15.41,7.41L14,6L8,12L14,18L15.41,16.58Z" /></svg>
	</span>
	<span class="screen-reader-text">Previous Alert</span>
</button>

<div class="alert-banner__counter" >
	<span class="alert-banner__counter__current js-alert-banner-counter-current"><!--
		-->1<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
<button class="alert-banner__next-control js-alert-banner-next">
	<span class="alert-banner__control-icon">
		<svg aria-hidden="true" tabindex="-1"  width="24" height="24" viewBox="0 0 24 24"><path d="M8.59,16.58L13.17,12L8.59,7.41L10,6L16,12L10,18L8.59,16.58Z" /></svg>
	</span>
	<span class="screen-reader-text">Next Alert</span>
</button>

			<div class="alert-banner__content">
								<a
					class="alert-banner__label js-alert-banner-primary-label"
					href="https://www.rochesterfirst.com/weather/closings/"
				>Closings</a>
				<div class="alert-banner__messages js-alert-banner-messages alert-banner__messages--truncated">

									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							ABC Head Start													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->1<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Albion Central													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->2<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							ARC of Genesee/Orleans Albion location													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->3<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							ARC of Genesee/Orleans Batavia location													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->4<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Attica Central													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->5<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Bill Gray&#039;s Regional Iceplex													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->6<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Bop Shop Records													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->7<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Brighton Library													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->8<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Brockport Free Methodist Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->9<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Browncroft Comm. Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->10<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Calvary Assembly of God													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->11<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							CDS Monarch													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->12<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Child Care Council													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->13<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Crossway Assembly													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->14<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Easter Seals-Kessler Ctr.													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->15<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Eastside Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->16<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Fairport Public Library													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->17<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Finger Lakes Secondary School-Gorham													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->18<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Finger Lakes WIC-Fairport													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->19<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							First Bible Baptist Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->20<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Fit by Five (Penfield)													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->21<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Gates Presbyterian Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->22<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							George Eastman Museum													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->23<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Glory to Glory Christian Fllwshp													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->24<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Henrietta Recreation Dept.													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->25<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Hilltop Industries													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->26<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Holy Cross School													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->27<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Hope Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->28<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Ibero Centro de Oro (Senior Ctr.)													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->29<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Ibero Early Childhood Ctr.													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->30<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Keuka Lake School													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->31<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							KidStart-Lehman													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->32<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Koinonia Fellowship													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->33<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Lifetime Assistance													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->34<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Literacy West NY-Batavia													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->35<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Literacy West NY-Belmont													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->36<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Literacy West NY-Mt. Morris													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->37<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Literacy West NY-Warsaw													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->38<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Maple Sugar Festival													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->39<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Mary Cariola Childrens Ctr.													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->40<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Memorial Art Gallery													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->41<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Messiah Lutheran Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->42<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Mountain Rise United Church of Christ													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->43<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Northside Christian Academy													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->44<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Open Door Baptist Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->45<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Orleans Co. Christian													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->46<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Parish of the Holy Family - Gates													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->47<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Park Ridge Child Care Center													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->48<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Pearce Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->49<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Perinton Community Center													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->50<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Perinton Presbyterian Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->51<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Perinton VFW 8495													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->52<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Pinnacle Lutheran Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->53<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							R Community Bikes													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->54<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Rainbow Preschool(Albion)													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->55<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Rainbow Preschool(Batavia)													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->56<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Renaissance Acad. School of the Arts													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->57<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Rochester Easter Egg Hunt													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->58<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Rochester Public Library													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->59<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Sharp Edgez Barber Inst.													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->60<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Southside Church of Christ													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->61<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Spencerport First Congregational Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->62<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Spiritus Christi Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->63<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							St. Joseph School (Batavia)													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->64<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							St. Luke&#039;s Episcopal Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->65<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Town of Rush Recreation Department													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->66<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Town of Walworth													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->67<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Trinity Lutheran Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->68<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Unistel Industries													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->69<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Villa of Hope School													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->70<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Village of E. Rochester													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->71<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Warsaw Head Start													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->72<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Webster Baptist Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->73<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
									<a href="https://www.rochesterfirst.com/weather/closings/" class="alert-banner__message js-alert-banner-message">

						<div class="alert-banner__message__content js-alert-banner-message-content">
							<div class="alert-banner__label" aria-hidden="true">Closings</div>
							Zion Hill Missionary Baptist Church													</div>

						
<div class="alert-banner__counter" aria-hidden="true">
	<span class="alert-banner__counter__current "><!--
		-->74<!--
	--></span>
	<span class="alert-banner__counter__sep--small-screens">&nbsp;of&nbsp;</span>
	<span class="alert-banner__counter__sep--large-screens" aria-hidden="true">/</span>
	<span class="alert-banner__counter__total">74</span>
</div>
					</a>
				
				</div>
			</div>
		</div>
	</div>


	<div class="weather-alerts" data-react-component="WeatherAlerts"></div>
</div>


			
<div id="content" class="site-content">
	<aside class="ad-unit ad-unit--leaderboard">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-billboard1-billboard1"   data-slot='{"pos":"billboard1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90],[970,250],[970,90],[970,30]]],[[1024,0],[[728,90],[970,250],[970,90],[970,30]]],[[768,0],[[728,90]]],[[641,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"billboard1","tag_id":"billboard1","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"billboard1","fold":"atf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-billboard1-billboard1'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>

			<div class="zone-container--below-supernav">
			<section id="custom_html-146" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><!--<html>

<head>
<script type="text/javascript">
        var clicked = "https://www.rochesterfirst.com/news/your-local-election-hq/primary-voter-guide-all-the-races-and-candidates-for-the-june-23rd-elections/";</script>
<style type="text/css">
        #videoBox {
            margin: 0;
            padding: 0;
            max-height: 250px;
            max-width: 1200px;
					width:100%;
            cursor: pointer;
            overflow:hidden;
        }
    </style>
</head>

<body>
<div id="videoBox" onclick="javascript:window.location.assign(clicked);">
<video muted id="video" autoplay="autoplay" loop="loop" max-width="1200" width="100%" max-height="250"> <source src="data:video/mp4;base64,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" type="video/mp4" />
</video>
	</div>
</body>

</html>
--></div></div></section>		</div>
	
	
	<div class="site-content__layout site-content__layout--has-sidebar">
		
		
		
		<div id="primary" class="content-area">
			<main id="main" class="site-main">

				
<article class="article post-464337 feed_post type-feed_post status-publish hentry category-politics" data-component="article">
	
<header class="article-header">
	<h1 class="article-title">
		Careers hang on mail-in ballots for 2 House Democrats	</h1>

			<div class="article-eyebrow">
			<a href="https://www.rochesterfirst.com/news/politics/">Politics</a>
		</div>
	
	
	<div class="article-meta">
					<p>by: KAREN MATTHEWS, Associated Press</p>
		
					Posted: <time datetime="2020-06-30T09:37:16-04:00">Jun 30, 2020 / 09:37 AM EDT</time>		
					<span class="article-meta--sep"> / </span>Updated: <time datetime="2020-06-30T09:37:16-04:00">Jun 30, 2020 / 09:37 AM EDT</time>			</div><!-- .article-meta -->

	
	<div class="article-lead-share">
		
<div data-component="addThisInline" class="social-share addthis">
	<div class="addthis_inline_share_toolbox"></div>
</div>
	</div>
</header><!-- .article-header -->

	<section id="custom_html-131" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><link rel="stylesheet" href="https://media.nbc4i.com/nxs-wcmhtv-media-us-east-1/css/alertbar2.css">
<style type="text/css">
  .desktopbar{
    max-width:1160px;
  }
  .desktop-item{
    margin:0px 10px 0px 0px;
    font-family: "Roboto Condensed", arial, helvetica, verdana, sans-serif;
    font-size:16px;
  }
	.desktop-item img{
		height:auto !important;
	}
  a{
    text-decoration:none;
    font-weight: 700;
  }
</style>
<div class="desktopbar">
	<div class="desktop-item">
		<a href="https://www.rochesterfirst.com/coronavirus/covid-19-county-by-county-keeping-track-of-local-cases-throughout-the-rochester-region/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/03/county.jpg?resize=640,360" alt="County by County COVID-19 Counter"><br />County by County COVID-19 Counter</a>
	</div>
	<div class="desktop-item">
		<a href="https://www.rochesterfirst.com/open-for-business/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/03/OpenForBusiness-16x9-2.jpg?resize=640,360" alt="Open For Business"><br />Open For Business</a>
	</div>
	<div class="desktop-item">
		<a href="https://www.rochesterfirst.com/coronavirus/johns-hopkins-offers-live-interactive-map-of-global-coronavirus-cases/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/hopkins_42320.jpg" alt="Live, Interactive Map of Global Coronavirus Cases"><br />Live, Interactive Map of Global Coronavirus Cases</a>
	</div>
	<div class="desktop-item">
		<a href="https://www.rochesterfirst.com/news/honor-roll/honor-roll-senior-salute/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/05/SeniorSaluteWebFS.jpg" alt="Class of 2020 High School Senior Salute"><br />Class of 2020 High School Senior Salute</a>
	</div>
	
</div>

<div class="mobilebar">
	<div class="mobile-item">
		<a href="https://www.rochesterfirst.com/coronavirus/covid-19-county-by-county-keeping-track-of-local-cases-throughout-the-rochester-region/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/CountyCoronaMobile.jpg" alt="County By County Coronavirus Tracker"></a>
	</div>
	<div class="mobile-item">
		<a href="https://www.rochesterfirst.com/open-for-business/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/OpenCoronaMobile.jpg" alt="Open For Business"></a>

	</div>
	<div class="mobile-item">
		<a href="https://www.rochesterfirst.com/coronavirus/johns-hopkins-offers-live-interactive-map-of-global-coronavirus-cases/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/LiveMapCoronaMobile.jpg" alt="Live, Interactice Map of Global Coronavirus Cases"></a>
	</div>
	<div class="mobile-item">
		<a href="https://www.rochesterfirst.com/news/honor-roll/honor-roll-senior-salute/"><img class="boxitem" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/05/SeniorSaluteMobile.jpg" alt="Class of 2020 High School Senior Salute"></a>
	</div>
	
</div>
</div></div></section>
	<div class="article-content rich-text">
		
		
<p>NEW YORK (AP) — New York Democrats Eliot Engel and Carolyn Maloney have cruised to reelection through most of their decades in Congress. Now, both must wait for mail-in ballots to be counted — a process that begins Wednesday — to learn whether they will serve an additional term.</p>

<p>Voting in New York&#8217;s primary election concluded June 23, but an unknown number of ballots have continued to trickle in by mail over the past week.</p>

<p>With potentially as much as 50% of the vote being cast by mail this year because of the coronavirus, absentee ballots could decide the primary election. Under state law, counting may begin Wednesday, but it could take several days to complete in some counties.</p>

<p>The most closely watched contest in New York is the one involving Engel, chairman of the House Foreign Affairs Committee.</p>

<p>Engel, who has been in Congress since 1989, was running well behind former middle school principal Jamaal Bowman in votes cast in person.</p>

<p>The Associated Press has not declared a winnerin the race, but Bowman, a progressive endorsed by Rep. Alexandria Ocasio-Cortez and Sen. Bernie Sanders, declared victory the day after the primary in a district that includes parts of the Bronx and suburban Westchester County.</p>

<p>&#8220;From the very beginning, we anchored our campaign in the fight for racial and economic justice,&#8221; Bowman said in a prepared statement. “We spoke the truth — about the police, about systemic racism, about inequality — and it resonated in every part of the district.”</p>

<p>Engel cautioned at the time that any such declaration &#8220;is premature and undermines the democratic process.”</p>

<p>Maloney, who is in her 14th term in Congress, was running just a few hundred votes ahead of her closest challenger, Suraj Patel.</p>

<p>Maloney said she expects her lead to grow when all the ballots are counted in the district that includes Manhattan’s wealthy Upper East Side, as well as waterfront neighborhoods in Brooklyn and Queens that have been a hotbed of progressive activism.</p>

<p>Patel, a 36-year-old lawyer, activist and lecturer on business ethics at New York University, also expressed confidence, saying many requests for absentee ballots came from younger voters whose support he expects to win.</p>

<p>“We’re in this race to ensure that the electorate is expanded, that every voice is heard, that every ballot is counted,” he said in a telephone interview.</p>

<p>“This is a change election,&#8221; he said. &#8220;Voters in droves rejected a failed status quo, and Carolyn Maloney with it.”</p>

<p>The race between Maloney and Patel is a rematch of the 2018 Democratic primary, a bruising contest that Maloney won while, one congressional district over, Ocasio-Cortez was ousting U.S. Rep. Joseph Crowley.</p>

<p>Patel, who had to take a break from the campaign trail after he was infected with the coronavirus, has sought to capitalize on some of the same forces that propelled Ocasio-Cortez to victory. The son of immigrants from India, he is young, progressive and campaigning on the idea that Maloney hasn&#8217;t pushed hard enough for change in Washington.</p>

<p>He ran, however, without the backing of some of the most influential groups on the left, including Justice Democrats and the Democratic Socialists of America.</p>

<p>Maloney attacked Patel in a digital ad that called him “creepy” over a 2012 Facebook post in which he joked about being attracted to Olympic gymnast McKayla Maroney, then just 16.</p>

<p>Patel said the comment about Maroney was “a flippant remark on social media to my girlfriend. It wasn’t made ever in real life to an underage girl. I would never have had that interaction.”</p>

<p>He filed complaint with the House Ethics Committee over Maloney&#8217;s campaign ad, saying the word creepy “is a racist trope used to describe black and brown men by people in power.”</p>

<p>Patel also attacked Maloney over questions she raised years ago about whether vaccines are linked to autism, prompting Maloney to run TV ads declaring that vaccines are safe.</p>

<p>Maloney, 74, called the election an opportunity to highlight her record and “talk about the opportunities ahead to advance police and criminal justice reform, to expand assistance to the millions impacted by COVID-19, and to hold President Trump accountable in what we are working to ensure are the final months of his disastrous presidency.”</p>

		

		<div class="article-content-cta-group">
					</div>
	</div><!-- .rich-text -->

	
<footer class="article-footer">
			<p class="article-copyright">Copyright 2020 The Associated Press. All rights reserved. This material may not be published, broadcast, rewritten or redistributed.</p>
	
	
	<div class="article-footer-share">
					<h2 class="article-footer-share__heading">Share this story</h2>
				
<div data-component="addThisInline" class="social-share addthis">
	<div class="addthis_inline_share_toolbox"></div>
</div>
	</div>
</footer><!-- .article-footer -->

	<aside class="ad-unit ad-unit--mr1-mobile">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-mr1_mobile-mr1_mobile"   data-slot='{"pos":"mr1_mobile","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[900,0],[]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"mr1_mobile","tag_id":"mr1_mobile","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"mr1_mobile","fold":"atf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr1_mobile-mr1_mobile'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>

	
	<div
		id="widget1"
		data-rc-widget
		data-widget-host="habitat"
		data-endpoint="trends.revcontent.com"
		data-widget-id="114878"
	></div>
	<script src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script> 	
	</article>

	<aside class="article-list article-list--full-width">
		
	<h2 class="article-list__heading article-list__heading--notched">
		More Politics Stories	</h2>


<div class="article-list__content">
						<a class="article-list__blanketing-link" href="https://www.rochesterfirst.com/news/politics/senate-extends-small-business-coronavirus-relief-program/">
		
		<article
			class="article-list__article article-list__article--is-stacked  article-list__article--has-excerpt"
			data-article-id="465085"
			data-index="0"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Senate extends small business coronavirus relief program
					</h3>
	
			<footer class="article-list__article-byline">
			by ANDREW TAYLOR, Associated Press <span class="sep">/</span> <time datetime="2020-06-30T21:23:52-04:00">Jun 30, 2020</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>WASHINGTON (AP) — Democrats drove a temporary extension of a popular subsidy program for small businesses through the GOP-controlled Senate late Tuesday, an unexpected development that came as spikes in coronavirus cases in many states are causing renewed shutdowns of bars and other businesses.</p>
<p>The move by Maryland Sen. Ben Cardin came hours before a deadline for applying for the program, which was created in March and modified twice since. Cardin, the top Democrat on the Small Business Committee, asked for unanimous approval of the extension of the Paycheck Protection Program through Aug. 8. </p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

		</article>

					</a>
		
							<aside class="ad-unit ad-unit--leader-mr3 ad-unit--is-embedded">
				<div class="ad-unit__content">
					  <div   id="acm-ad-tag-leader_mr3-leader_mr3"   data-slot='{"pos":"leader_mr3","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1152,0],[[728,90]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leader_mr3","tag_id":"leader_mr3","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"leader_mr3","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leader_mr3-leader_mr3'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  				</div>
			</aside>
							<a class="article-list__blanketing-link" href="https://www.rochesterfirst.com/news/politics/biden-and-trump-agree-november-election-could-be-corrupt/">
		
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--has-excerpt"
			data-article-id="465075"
			data-index="1"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Biden and Trump agree: November election could be corrupt
					</h3>
	
			<footer class="article-list__article-byline">
			by BILL BARROW, Associated Press <span class="sep">/</span> <time datetime="2020-06-30T20:39:09-04:00">Jun 30, 2020</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>ATLANTA (AP) — President Donald Trump and his challenger, Joe Biden, have found something they agree on: The November election could be rife with corruption because of how officials handle the voting process.</p>
<p>Of course, the Republican incumbent and his Democratic rival place the prospective blame in different places. Each points at the other’s party.</p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=2560&#038;h=1440&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/42e1347514d046c0822d2c1b6b39a919.jpg?w=2560&amp;h=1440&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

			</figure>
			</article>

					</a>
		
									<a class="article-list__blanketing-link" href="https://www.rochesterfirst.com/news/politics/report-shows-480000-in-donations-to-cover-pence-legal-aid/">
		
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--has-excerpt"
			data-article-id="464980"
			data-index="2"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Report shows $480,000 in donations to cover Pence legal aid
					</h3>
	
			<footer class="article-list__article-byline">
			by KEVIN FREKING, Associated Press <span class="sep">/</span> <time datetime="2020-06-30T18:23:07-04:00">Jun 30, 2020</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>WASHINGTON (AP) — Donors contributed nearly $480,000 last year to cover Vice President Mike Pence’s legal expenses from special counsel Robert Mueller’s probe of Russian meddling in the 2016 elections, according to Pence’s financial disclosure report.</p>
<p>The annual report, released Tuesday, shows that a dozen donors contributed to the trust fund in May of last year. The amounts ranged from $100,000 for the top three donors to $25 for the person who is listed as the fund’s trustee, James Atterholt, who served as Pence’s chief of staff from 2014 through 2016 when Pence was governor of Indiana.</p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=2560&#038;h=1440&#038;crop=1"
		alt="Mike Pence"
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/360b5daab83d4d83b3df8cf5dd00aa2f.jpg?w=2560&amp;h=1440&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

			</figure>
			</article>

					</a>
		
				
</div>



	</aside>
	
<aside class="ad-unit ad-unit--leader-mr1">
	<div class="ad-unit__content">
		  <div   id="acm-ad-tag-leader_mr1-leader_mr1-story-pages"   data-slot='{"pos":"leader_mr1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1152,0],[[728,90]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leader_mr1","tag_id":"leader_mr1 Story pages","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"leader_mr1","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leader_mr1-leader_mr1-story-pages'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  	</div>
</aside>

	<section class="article-list-group">
		<aside class="article-list article-list--grid article-list--grid-3">
			
	<h2 class="article-list__heading article-list__heading--notched">
		Top Stories	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="465129"
			data-index="0"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/woman-25-in-critical-condition-after-riding-on-vehicles-roof/"
									>
			
				Woman, 25, in critical condition after riding on vehicle roof
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/local-news/woman-25-in-critical-condition-after-riding-on-vehicles-roof/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=706&#038;h=396&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=706&amp;h=396&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=706&amp;h=396&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=706&amp;h=396&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/04/Police-lights-911-cops-stabbing-shooting-investigation-robbery-arrested-jail-prison-sirens.jpg?w=706&amp;h=396&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="58851"
			data-index="1"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
									>
			
				Weather forecast: Hello, July!
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&#038;h=720&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="465094"
			data-index="2"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/crime/police-looking-for-suspects-after-shooting-on-citys-northeast-side/"
									>
			
				Police looking for suspects after shooting on city&#8217;s northeast side
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/crime/police-looking-for-suspects-after-shooting-on-citys-northeast-side/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/ernst-st.jpg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464935"
			data-index="3"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/1-new-covid-19-death-in-monroe-county-33-new-confirmed-cases-76-hospitalized/"
									>
			
				1 new COVID-19 death in Monroe County, 33 new confirmed cases, 76 hospitalized
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/coronavirus/1-new-covid-19-death-in-monroe-county-33-new-confirmed-cases-76-hospitalized/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/testing-2.jpg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464909"
			data-index="4"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/fairport-business-owners-welcoming-back-boaters-as-erie-canal-boat-traffic-reopens/"
									>
			
				Fairport business owners welcoming back boaters as Erie Canal boat traffic reopens
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/coronavirus/fairport-business-owners-welcoming-back-boaters-as-erie-canal-boat-traffic-reopens/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5636846"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/0D3DBD1DC79A4FDF97252C89CB269865.jpeg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464892"
			data-index="5"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/aaa-road-trips-will-make-up-97-of-summer-travel/"
									>
			
				AAA: Road trips will make up 97% of summer travel
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/coronavirus/aaa-road-trips-will-make-up-97-of-summer-travel/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5636669"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/5D9E8B1EF9FB465FA2254C43F8944227.jpeg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
				
</div>



		</aside>

		<aside class="ad-unit ad-unit--leader-mr4">
			<div class="ad-unit__content">
				  <div   id="acm-ad-tag-leader_mr4-leader_mr4-facebook-users-only"   data-slot='{"pos":"leader_mr4","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1152,0],[[728,90]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leader_mr4","tag_id":"leader_mr4 Facebook Users only","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":"1"}'   data-targeting='{"pos":"leader_mr4","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leader_mr4-leader_mr4-facebook-users-only'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  			</div>
		</aside>

					<aside class="article-list article-list--grid article-list--grid-3">
				


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464710"
			data-index="0"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather-blog/gallery-finger-lakes-toxic-algae-is-becoming-a-threat-heading-into-july-4-weekend/"
									>
			
				Gallery: Finger Lakes toxic algae is becoming a threat heading into July 4 weekend
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/weather-blog/gallery-finger-lakes-toxic-algae-is-becoming-a-threat-heading-into-july-4-weekend/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&#038;h=325&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&amp;h=325&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&amp;h=325&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&amp;h=325&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&amp;h=325&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/bubblscum1.jpg?w=490&amp;h=325&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--gallery"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="16" height="14" viewBox="0 0 16 14"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="gallery_small_carousel_button_default" data-name="gallery small carousel button default" class="cls-1" d="M828 1055h12v10h-12v-10zm2 2h8v6h-8v-6zm4 12h10v-10h-2v8h-8v2z" transform="translate(-828 -1055)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Gallery</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464804"
			data-index="1"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/sports/red-wings/minor-league-baseball-officially-cancels-2020-season/"
									>
			
				Minor League Baseball officially cancels 2020 season, 1st summer since 1898 with no baseball in Rochester
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/sports/red-wings/minor-league-baseball-officially-cancels-2020-season/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=742&#038;h=356&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=640&amp;h=356&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=742&amp;h=356&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=742&amp;h=356&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=742&amp;h=356&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Frontier20Field20preps20for20opening20day_7873511_ver1.0-e1586490545524.jpg?w=742&amp;h=356&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464814"
			data-index="2"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/large-police-presence-on-rochesters-northeast-side/"
									>
			
				Large police presence on Rochester&#8217;s northeast side after 22-year-old male shot
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/local-news/large-police-presence-on-rochesters-northeast-side/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=960&#038;h=540&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=960&amp;h=540&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=960&amp;h=540&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/hudson_police_investigation_63020_1.jpg?w=960&amp;h=540&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--gallery"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="16" height="14" viewBox="0 0 16 14"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="gallery_small_carousel_button_default" data-name="gallery small carousel button default" class="cls-1" d="M828 1055h12v10h-12v-10zm2 2h8v6h-8v-6zm4 12h10v-10h-2v8h-8v2z" transform="translate(-828 -1055)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Gallery</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464520"
			data-index="3"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather-blog/lake-ontario-water-levels-continue-to-drop-ijc-releases-summer-outlook/"
									>
			
				Lake Ontario water levels continue to drop; IJC releases summer outlook
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/weather-blog/lake-ontario-water-levels-continue-to-drop-ijc-releases-summer-outlook/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=800&#038;h=533&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=800&amp;h=533&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=800&amp;h=533&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=800&amp;h=533&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/MSD.jpeg?w=800&amp;h=533&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464610"
			data-index="4"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/digital-exclusives/canandaigua-woman-arrested-trespassing-in-kangaroo-owners-backyard/"
									>
			
				Canandaigua woman arrested for trespassing in kangaroo owner&#8217;s backyard
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/digital-exclusives/canandaigua-woman-arrested-trespassing-in-kangaroo-owners-backyard/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5636013"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/HARPER-AND-RYDER.jpg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464557"
			data-index="5"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h2 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/monroe-county-district-attorneys-office-employee-resigns-after-controversial-social-media-post/"
									>
			
				Monroe County Assistant District Attorney resigns after controversial social media post
							</a>
					</h2>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/local-news/monroe-county-district-attorneys-office-employee-resigns-after-controversial-social-media-post/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5636267"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/strollo_floyd_post_63020_1_2.jpg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
				
</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="/news/">
			Read more stories
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	

			</aside>
			</section>

			<aside class="ad-unit ad-unit--leader-mr2">
			<div class="ad-unit__content">
				  <div   id="acm-ad-tag-leader_mr2-leader_mr2"   data-slot='{"pos":"leader_mr2","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1152,0],[[728,90]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leader_mr2","tag_id":"leader_mr2","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"leader_mr2","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leader_mr2-leader_mr2'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  			</div>
		</aside>
			<aside class="article-list article-list--grid article-list--grid-2">
		
	<h2 class="article-list__heading article-list__heading--notched">
		More Stories	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464509"
			data-index="0"
			data-collection="article-list4"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list4"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/webster-town-judge-faces-reprimand-by-new-york-state/"
									>
			
				Webster town judge faces reprimand by New York State
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/local-news/webster-town-judge-faces-reprimand-by-new-york-state/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=1912&#038;h=1075&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=1912&amp;h=1075&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/WebsterJustice.jpg?w=1912&amp;h=1075&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464471"
			data-index="1"
			data-collection="article-list4"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list4"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/eight-more-states-added-to-the-required-quarantine-list/"
									>
			
				8 more states added to travel advisory, requiring incoming travelers to quarantine for 14 days
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/coronavirus/eight-more-states-added-to-the-required-quarantine-list/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5636274"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=2560&#038;h=1440&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Cuomo-2-2.jpg?w=2560&amp;h=1440&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464454"
			data-index="2"
			data-collection="article-list4"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list4"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/reimagining-ny/reimagining-ny-blurring-the-lines-of-in-person-and-virtual-learning/"
									>
			
				Reimagining NY: Blurring the lines of in-person and virtual learning
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/reimagining-ny/reimagining-ny-blurring-the-lines-of-in-person-and-virtual-learning/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5635551"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=1920&#038;h=1080&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/classroom_generic_school_learning_teaching_63020_1.jpg?w=1920&amp;h=1080&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="464305"
			data-index="3"
			data-collection="article-list4"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list4"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/state-news/gyms-threaten-class-action-lawsuit-against-gov-cuomo/"
									>
			
				Gyms threaten class action lawsuit against Gov. Cuomo
							</a>
					</h3>
	
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.rochesterfirst.com/news/state-news/gyms-threaten-class-action-lawsuit-against-gov-cuomo/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape square-on-mobile vilynx_enabled"
			data-vilynx-id="LIN_5634372"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&#038;h=252&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&amp;h=252&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&amp;h=252&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&amp;h=252&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&amp;h=252&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/01CA265E3DE24BEABF064F3BCAD7D250.jpg?w=448&amp;h=252&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

		
				
</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="/news/">
			Read more stories
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	

	</aside>
	
			</main>
		</div>

		
<section id="secondary" class="widget-area">
	<!-- Ad Unit Square -->
	<aside class="ad-unit ad-unit--square">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-mr_combo1-mr_combo1"   data-slot='{"pos":"mr_combo1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1280,0],[[300,600],[300,250]]],[[1024,0],[[300,600],[300,250]]],[[768,0],[[300,250]]],[[641,0],[[300,250]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"mr_combo1","tag_id":"mr_combo1","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"mr_combo1","fold":"atf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr_combo1-mr_combo1'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>
	<!-- END Ad Unit Square -->

	
<aside class="weather-widget">
	<h2 class="weather-widget__heading">Today&#039;s Forecast</h2>
	<a class="weather-widget__content" href="https://www.rochesterfirst.com/weather/">
		<div class="weather-widget__item">
			<h4 class="weather-widget__item-day">Current</h4>
			<h5 class="weather-widget__item-temperature">
				69&deg;			</h5>
			<figure class="weather-widget__item-icon">
				<span class="weather-icon weather-icon-sm weather-icon-dark-98"></span>
			</figure>
			<span class="weather-widget__item-conditions">Scattered Clouds</span>
		</div>

		<div class="weather-widget__item">
			<h4 class="weather-widget__item-day">Tonight</h4>
			<h5 class="weather-widget__item-temperature">
				62&deg;			</h5>
			<figure class="weather-widget__item-icon">
				<span class="weather-icon weather-icon-sm weather-icon-dark-97"></span>
			</figure>
			<span class="weather-widget__item-conditions">Mostly Clear</span>
			<span class="weather-widget__item-precipitation">
				Precip: 0&percnt;			</span>
		</div>

		<div class="weather-widget__item">
			<h4 class="weather-widget__item-day">Tomorrow</h4>
			<h5 class="weather-widget__item-temperature">
				82&deg;			</h5>
			<figure class="weather-widget__item-icon">
				<span class="weather-icon weather-icon-sm weather-icon-dark-66"></span>
			</figure>
			<span class="weather-widget__item-conditions">Partly cloudy</span>
			<span class="weather-widget__item-precipitation">
				Precip: 10&percnt;			</span>
		</div>
	</a>
</aside>
<section id="custom_html-139" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><a href="https://www.rochesterfirst.com/destination-ny/"> <img alt="Destination NY" src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/Destination-NY-Button_900x750.jpg" width="100%" /></a></div></div></section><section id="ns-article-bin-29" class="widget widget_ns-article-bin">			<section
				class="article-list article-list--trending"
				data-component=""
				data-context="numbered_list"
								data-carousel-duration="0"
			>
				
	<h2 class="article-list__heading article-list__heading--bottom-divider">
		Trending Stories	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="462505"
			data-index="0"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/economy/second-stimulus-check-is-very-likely-coming-in-july-u-s-senate-said/"
									>
			
				Second stimulus check is very likely coming in July, U.S. Senate said
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464814"
			data-index="1"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/large-police-presence-on-rochesters-northeast-side/"
									>
			
				Large police presence on Rochester&#8217;s northeast side after 22-year-old male shot
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--gallery"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="16" height="14" viewBox="0 0 16 14"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="gallery_small_carousel_button_default" data-name="gallery small carousel button default" class="cls-1" d="M828 1055h12v10h-12v-10zm2 2h8v6h-8v-6zm4 12h10v-10h-2v8h-8v2z" transform="translate(-828 -1055)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Gallery</span>
	</span>
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="463991"
			data-index="2"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/developing-police-bomb-squad-on-scene-in-penfield/"
									>
			
				Penfield standoff ends peacefully after 24 hours, no injuries reported, charges announced Wednesday
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464935"
			data-index="3"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/1-new-covid-19-death-in-monroe-county-33-new-confirmed-cases-76-hospitalized/"
									>
			
				1 new COVID-19 death in Monroe County, 33 new confirmed cases, 76 hospitalized
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464557"
			data-index="4"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/monroe-county-district-attorneys-office-employee-resigns-after-controversial-social-media-post/"
									>
			
				Monroe County Assistant District Attorney resigns after controversial social media post
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464471"
			data-index="5"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/coronavirus/eight-more-states-added-to-the-required-quarantine-list/"
									>
			
				8 more states added to travel advisory, requiring incoming travelers to quarantine for 14 days
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464110"
			data-index="6"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/local-news/black-lives-matter-organizers-question-if-new-alliance-will-make-a-difference/"
									>
			
				Local Black lives Matter organizers question new community-police alliance, say they were not consulted
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat"
			data-article-id="464610"
			data-index="7"
			data-collection="article-list5"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list5"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/news/digital-exclusives/canandaigua-woman-arrested-trespassing-in-kangaroo-owners-backyard/"
									>
			
				Canandaigua woman arrested for trespassing in kangaroo owner&#8217;s backyard
							</a>
					</h3>
	
	
	
	
			
<span
	aria-hidden="true"
	tabindex="-1"
	class="article-list__article-mediaicon article-list__article-mediaicon--video"
>
	<span class="article-list__article-mediaicon-svg">
		<svg xmlns="http://www.w3.org/2000/svg" width="11" height="13" viewBox="0 0 11 13"><defs><style>.cls-1{fill:#fff;fill-rule:evenodd}</style></defs><path id="video_small_carousel_button_default" data-name="video small carousel button default" class="cls-1" d="M842 1167.5l-11 6.5v-13z" transform="translate(-831 -1161)"/></svg>	</span>
			<span class="article-list__article-mediaicon-text">Video</span>
	</span>
	</div>

		</article>

		
				
</div>



			</section>
			</section><section id="ns-article-bin-2" class="widget widget_ns-article-bin">			<section
				class="article-list article-list--story-grid article-list--story-grid--one-col"
				data-component=""
				data-context="headline_list"
								data-carousel-duration="0"
			>
				
	<h2 class="article-list__heading">
		Don't Miss	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-article-id="58851"
			data-index="0"
			data-collection="article-list6"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list6"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
									>
			
				Weather forecast: Hello, July!
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.rochesterfirst.com/weather/weather-forecasts/">Weather Forecasts</a> / <time datetime="2020-06-30T22:00:10-04:00">2 hours ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
					<a
				href="https://www.rochesterfirst.com/weather/weather-forecasts/todays-forecast/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div
	class="image-wrapper landscape"
	>
	<img
		src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&#038;h=720&#038;crop=1"
		alt=""
		srcset="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 1920w, https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/06/EbyCQNWXYAAETmp.jpg?w=1280&amp;h=720&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, 300px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-article-id="56716"
			data-index="1"
			data-collection="article-list6"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list6"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="/adam-interviews/"
									>
			
				Adam Interviews
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.rochesterfirst.com/dont-miss/">Don&#039;t Miss</a> / <time datetime="2019-08-06T11:54:14-04:00">11 months ago</time>		</footer>
	
	
	
	</div>

		</article>

		
						
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-article-id="60"
			data-index="2"
			data-collection="article-list6"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list6"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="/games"
									>
			
				Games and Puzzles
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.rochesterfirst.com/entertainment-news/">Entertainment</a> / <time datetime="2019-09-11T10:59:30-04:00">10 months ago</time>		</footer>
	
	
	
	</div>

		</article>

		
				
</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="">
			More Don&#039;t Miss
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	

			</section>
			</section><section id="custom_html-92" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><style type="text/css">
	#ns-article-bin-2 .article-list__article-meta{
		display:none;
	}

</style></div></div></section>
			<!-- Ad Unit Square -->
		<aside class="ad-unit ad-unit--square">
			<div class="ad-unit__content">
				  <div   id="acm-ad-tag-mr1-mr1"   data-slot='{"pos":"mr1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1280,0],[[300,250]]],[[1024,0],[[300,250]]],[[768,0],[[300,250]]],[[641,0],[[300,250]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"mid"}'   data-unit='{"tag":"mr1","tag_id":"mr1","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"mr1","fold":"mid","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr1-mr1'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  			</div>
		</aside>
		<!-- END Ad Unit Square -->
	
	
			<!-- Nativo -->
		<div id="native-rr"></div>
		<!-- END Nativo -->
	
	
	<section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><!--<div style="width: 100%;"><div style="text-align: center;"><div data-cswidget="8119"></div><script type="text/javascript" async defer src="//portal.CitySpark.com/js/widget.min.js" > </script></div></div>--></div></div></section>
	<aside class="ad-unit ad-unit--square ad-unit--sticky">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-mr_combo2-mr_combo2"   data-slot='{"pos":"mr_combo2","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1280,0],[[300,600],[300,250]]],[[1024,0],[[300,600],[300,250]]],[[768,0],[[300,250]]],[[641,0],[[300,250]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"mr_combo2","tag_id":"mr_combo2","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"mr_combo2","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr_combo2-mr_combo2'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>
	<!-- END Ad Unit Square -->
</section><!-- #secondary -->
	</div>

			<aside class="ad-unit ad-unit--leaderboard">
			<div class="ad-unit__content">
				  <div   id="acm-ad-tag-leaderboard3-leaderboard3"   data-slot='{"pos":"leaderboard3","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90]]],[[1024,0],[[728,90]]],[[768,0],[[728,90]]],[[641,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leaderboard3","tag_id":"leaderboard3","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"leaderboard3","fold":"btf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leaderboard3-leaderboard3'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  			</div>
		</aside>
	
	
</div><!-- #content -->
		</div>

		<footer id="footer" class="site-footer">
	<div class="site-footer__site-branding">
		<div class="site-footer__logo">
			<a href="https://www.rochesterfirst.com/" rel="home">
				<img src="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/cropped-Rochester-First_Logo-copy.png" alt="WROC" />
			</a>
		</div>
	</div>

		<div class="site-footer__social">
		<h2>Follow Us</h2>
		
<aside class="social-links social-links--default">
	<ul class="social-links__list">
					<li class="social-links__list-item social-links__list-item--facebook">
				<a href="https://www.facebook.com/News8WROC">
					
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 58 58" style="enable-background:new 0 0 58 58;" xml:space="preserve">
	<title>Facebook</title>
	<style type="text/css">
		.facebook-st0{fill:#4267B2;}
		.facebook-st1{fill:#FFFFFF;}
	</style>
	<path class="facebook-st0" d="M54.8,0H3.2C1.43,0,0,1.43,0,3.2v51.6C0,56.57,1.43,58,3.2,58h0H31V35.57h-7.55v-8.78H31v-6.46
		c0-7.49,4.58-11.57,11.26-11.57c2.25,0,4.5,0.11,6.74,0.34v7.83h-4.6c-3.64,0-4.35,1.72-4.35,4.26v5.59h8.7l-1.13,8.78H40V58h14.8
		c1.77,0,3.2-1.43,3.2-3.2l0,0V3.2C58,1.43,56.57,0,54.8,0L54.8,0z"/>
	<path id="f" class="facebook-st1" d="M40,58V35.57h7.57l1.13-8.78H40V21.2c0-2.54,0.71-4.26,4.35-4.26H49V9.1c-2.24-0.23-4.5-0.35-6.75-0.34
	C35.56,8.76,31,12.84,31,20.33v6.46h-7.55v8.78H31V58H40z"/>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--twitter">
				<a href="https://twitter.com/News_8">
					
<svg version="1.1" id="Logo__x2014__FIXED" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 259.77 218.57" style="enable-background:new 0 0 33 33;" xml:space="preserve">
	<title>Twitter</title>
	<style type="text/css">
		.twitter-st0{fill:none;}
		.twitter-st1{fill:#1DA1F2;}
	</style>
	<g>
		<rect x="-69.49" y="-90.72" class="twitter-st0" width="400" height="400"/>
		<path class="twitter-st1" d="M84.13,210.87c94.34,0,145.94-78.16,145.94-145.94c0-2.22-0.05-4.43-0.15-6.63
			c10.01-7.24,18.72-16.27,25.59-26.56c-9.19,4.08-19.08,6.83-29.46,8.07c10.59-6.35,18.72-16.4,22.55-28.37
			c-9.91,5.88-20.89,10.15-32.57,12.45c-9.36-9.97-22.69-16.21-37.44-16.21c-28.33,0-51.3,22.97-51.3,51.29
			c0,4.03,0.45,7.94,1.33,11.69C86,68.53,48.2,48.12,22.91,17.09c-4.41,7.58-6.95,16.39-6.95,25.78c0,17.8,9.06,33.5,22.82,42.69
			c-8.41-0.26-16.32-2.57-23.23-6.42c-0.01,0.21-0.01,0.43-0.01,0.65c0,24.84,17.68,45.58,41.15,50.28c-4.31,1.17-8.84,1.8-13.52,1.8
			c-3.3,0-6.52-0.33-9.64-0.93c6.53,20.38,25.46,35.21,47.92,35.62c-17.56,13.76-39.67,21.96-63.7,21.96
			c-4.14,0-8.22-0.24-12.24-0.71C28.21,202.38,55.16,210.87,84.13,210.87"/>
	</g>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--instagram">
				<a href="https://www.instagram.com/news8_wroc/?hl=en">
					<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/social/instagram.png" alt="Instagram" />
				</a>
			</li>
									<li class="social-links__list-item social-links__list-item--youtube">
				<a href="https://www.youtube.com/channel/UCzocYTD8J3ezkaoND4iQPGA">
					
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 192 192" style="enable-background:new 0 0 192 192;" xml:space="preserve">
	<title>YouTube</title>
	<style type="text/css">
		.youtube-st0{fill:#FF0000;}
		.youtube-st1{fill:#FFFFFF;}
	</style>
	<g id="XMLID_184_">
		<path id="XMLID_182_" class="youtube-st0" d="M180.32,53.36c-2.02-7.62-7.99-13.62-15.56-15.66C151.04,34,96,34,96,34s-55.04,0-68.76,3.7
			c-7.57,2.04-13.54,8.04-15.56,15.66C8,67.18,8,96,8,96s0,28.82,3.68,42.64c2.02,7.62,7.99,13.62,15.56,15.66
			C40.96,158,96,158,96,158s55.04,0,68.76-3.7c7.57-2.04,13.54-8.04,15.56-15.66C184,124.82,184,96,184,96S184,67.18,180.32,53.36z"
			/>
		<polygon id="XMLID_1355_" class="youtube-st1" points="78,122.17 124,96 78,69.83 	"/>
	</g>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--rss">
				<a href="https://www.rochesterfirst.com/app-feed">
					
<svg xmlns="http://www.w3.org/2000/svg" width="25.66" height="26.875" viewBox="0 0 25.66 26.875">
	<title>RSS Feed</title>
	<defs>
		<style>
			.rss-cls-1 {
				fill: #1da64a;
				fill-rule: evenodd;
			}
		</style>
	</defs>
	<path class="rss-cls-1" d="M1069.12,199.9a3.3,3.3,0,0,0-2.48,1.07,3.817,3.817,0,0,0,0,5.195,3.409,3.409,0,0,0,4.96,0,3.817,3.817,0,0,0,0-5.195A3.3,3.3,0,0,0,1069.12,199.9Zm8.06-4.775a16.173,16.173,0,0,0-4.73-3.467,15.718,15.718,0,0,0-5.57-1.538h-0.1a1.042,1.042,0,0,0-.78.325,1.164,1.164,0,0,0-.38.9v2.579a1.211,1.211,0,0,0,.3.822,1.086,1.086,0,0,0,.75.382,11.111,11.111,0,0,1,7.14,3.524,12.117,12.117,0,0,1,3.37,7.478,1.153,1.153,0,0,0,.36.792,1.089,1.089,0,0,0,.78.316h2.47a1.044,1.044,0,0,0,.85-0.4,1.173,1.173,0,0,0,.31-0.917,17.83,17.83,0,0,0-1.46-5.845A17.228,17.228,0,0,0,1077.18,195.12Zm11.92,1.251a26.894,26.894,0,0,0-5.36-8.128,25.591,25.591,0,0,0-7.76-5.616,24.376,24.376,0,0,0-9.14-2.292h-0.06a1.074,1.074,0,0,0-.8.344,1.162,1.162,0,0,0-.36.879v2.731a1.17,1.17,0,0,0,.32.831,1.062,1.062,0,0,0,.77.373,19.909,19.909,0,0,1,7.45,1.948,20.954,20.954,0,0,1,6.12,4.422,21.822,21.822,0,0,1,4.22,6.418,22.1,22.1,0,0,1,1.85,7.8,1.174,1.174,0,0,0,.35.812,1.126,1.126,0,0,0,.81.334h2.61a1.06,1.06,0,0,0,.84-0.382,1.162,1.162,0,0,0,.33-0.9A27.61,27.61,0,0,0,1089.1,196.371Z" transform="translate(-1065.62 -180.344)"/>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--email">
				<a href="mailto:newsroom@wroctv.com">
					
<svg xmlns="http://www.w3.org/2000/svg" width="29.35" height="22" viewBox="0 0 29.35 22">
	<title>Email</title>
	<defs>
		<style>
			.email-cls-1 {
				fill: #eb6823;
				fill-rule: evenodd;
			}
		</style>
	</defs>
	<path class="email-cls-1" d="M1168.41,189.824a0.347,0.347,0,0,1,.56.269v11.719a2.75,2.75,0,0,1-2.75,2.751h-23.84a2.75,2.75,0,0,1-2.75-2.751V190.1a0.338,0.338,0,0,1,.55-0.269c1.29,1,2.99,2.263,8.83,6.51,1.21,0.882,3.25,2.739,5.29,2.727,2.04,0.017,4.12-1.879,5.29-2.727C1165.43,192.093,1167.13,190.821,1168.41,189.824Zm-14.11,7.4c1.33,0.023,3.24-1.674,4.2-2.373,7.61-5.518,8.19-6,9.94-7.375a1.381,1.381,0,0,0,.53-1.083v-1.089a2.75,2.75,0,0,0-2.75-2.75h-23.84a2.75,2.75,0,0,0-2.75,2.75V186.4a1.359,1.359,0,0,0,.53,1.083c1.75,1.37,2.33,1.857,9.93,7.375,0.96,0.7,2.88,2.4,4.21,2.373h0Z" transform="translate(-1139.62 -182.562)"/>
</svg>
				</a>
			</li>
			</ul>
</aside>
	</div>
	
		<div class="site-footer__apps">
		<h2>News App</h2>
		<div class="app-links">
							<div class="app-link">
					<a href="https://itunes.apple.com/us/app/wroc-news-8-rochesterfirst/id638930553?mt=8">
						<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/appstore_footer.png" alt="Get the iOS app" />
					</a>
				</div>
										<div class="app-link">
					<a href="https://play.google.com/store/apps/details?id=com.newssynergy.rochesterhomepage">
						<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/googleplay_footer.png" alt="Get the Android app from Google Play" />
					</a>
				</div>
					</div>
	</div>
	<div class="site-footer__weather-apps">
		<h2>Weather App</h2>
		<div class="app-links">
							<div class="app-link">
					<a href="https://itunes.apple.com/us/app/wroc-weather-8-rochesterfirst/id905416555?mt=8">
						<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/appstore_footer.png" alt="Get the iOS Weather app" />
					</a>
				</div>
										<div class="app-link">
					<a href="https://play.google.com/store/apps/details?id=com.newssynergy.wrocweather&#038;hl=en_US">
						<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/googleplay_footer.png" alt="Get the Android Weather app from Google Play" />
					</a>
				</div>
					</div>
	</div>
	
	
<div class="site-footer__primary-nav">
	<div class="menu-footer-primary-container"><ul id="menu-footer-primary" class="menu"><li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-41"><a href="https://www.rochesterfirst.com">Home</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-177"><a href="https://www.rochesterfirst.com/weather/">Weather</a></li>
<li id="menu-item-75958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75958"><a href="https://www.rochesterfirst.com/sports/">Sports</a></li>
<li id="menu-item-4441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4441"><a href="https://www.rochesterfirst.com/tv-schedule/">TV Schedule</a></li>
<li id="menu-item-143101" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143101"><a href="https://www.rochesterfirst.com/contests/">Contests</a></li>
<li id="menu-item-75960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75960"><a href="https://www.rochesterfirst.com/calendar/">Calendar</a></li>
<li id="menu-item-75962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75962"><a href="https://www.rochesterfirst.com/careers/">Work For Us</a></li>
<li id="menu-item-75961" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75961"><a href="https://www.rochesterfirst.com/meet-the-team/">Meet The Team</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43"><a href="https://www.rochesterfirst.com/contact-us/">Contact Us</a></li>
</ul></div></div>

<div class="site-footer__secondary-nav">
	<div class="menu-footer-secondary-container"><ul id="menu-footer-secondary" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="https://www.rochesterfirst.com/privacy-policy#advertising">About Our Ads</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47"><a href="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2020/01/WROC-TV-EEO_Public_File-2019-2020.pdf">WROC EEO Report</a></li>
<li id="menu-item-38" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38"><a href="https://publicfiles.fcc.gov/tv-profile/wroc-tv">WROC FCC Public Profile</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48"><a href="https://www.rochesterfirst.com/wp-content/uploads/sites/66/2019/06/NexstarCCCertification.pdf">Nexstar CC Certification</a></li>
</ul></div></div>

	
<div class="site-footer__network-nav site-footer__secondary-nav">
	<div class="menu">
		<ul>
							
											<li>
							<a
								href="https://www.nexstar.tv/privacy-policy/"
								target="_blank"
							>
								Privacy Policy							</a>
						</li>
					
											
											<li>
							<a
								href="https://www.rochesterfirst.com/terms-of-use/"
								target=""
							>
								Terms Of Use							</a>
						</li>
					
											
											<li>
							<a
								href="https://www.covers.com/"
								target="_blank"
							>
								Covers							</a>
						</li>
					
											
											<li>
							<a href="#" data-component="NexstarCCPA">Do Not Sell My Personal Information</a>						</li>
					
									</ul>
	</div>
</div>

	<div class="site-footer__network-branding">
								<a href="https://www.nexstar.tv" title="Go to Nexstar.tv">
				<img src="https://www.rochesterfirst.com/wp-content/themes/nexstar/client/src/images/footer/nexstar-logo-white-nmg.png" alt="Nexstar Logo">
			</a>
			</div>
	<div class="site-footer__copyright">
		&copy; 1998 - 2020 Nexstar Broadcasting, Inc. | All Rights Reserved.	</div>
</footer>
	</div><!-- #page -->

	
<script type='text/javascript'>
(function() {
	var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});

	_sf_async_config.sections = "Politics";
	_sf_async_config.authors = "KAREN MATTHEWS, Associated Press";
	function loadChartbeat() {
			var e = document.createElement('script');
			var n = document.getElementsByTagName('script')[0];
			e.type = 'text/javascript';
			e.async = true;
			e.src = '//static.chartbeat.com/js/chartbeat.js';
			n.parentNode.insertBefore(e, n);
	}
	loadChartbeat();
})();
</script>

	
	
	<aside class="ad-unit ad-unit--adhesion">
		<div class="ad-unit__content pre-render">
			<div class="close-btn-container">
				<div class="close-btn" aria-label="Close Viewport Adhesion Ad">&times; Close Ad</div>
			</div>
			  <div   id="acm-ad-tag-adhesion-adhesion"   data-slot='{"pos":"adhesion","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90]]],[[1024,0],[[728,90]]],[[768,0],[[728,90]]],[[480,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"adhesion","tag_id":"adhesion","dfp_id":"5678","tag_name":"nx.wroc","ad_disabled":"0","facebook_only":""}'   data-targeting='{"pos":"adhesion","fold":"atf","category":"politics","kw":"careers-hang-on-mail-in-ballots-for-2-house-democrats"}'   data-path='/5678/nx.wroc/news/politics'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-adhesion-adhesion'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>

	<div id="aria-dialog-overlay"></div>
	<script class="wp-asset-manager ns-ad-handler-js" type="text/javascript">!function(t){var e={};function n(o){if(e[o])return e[o].exports;var r=e[o]={i:o,l:!1,exports:{}};return t[o].call(r.exports,r,r.exports,n),r.l=!0,r.exports}n.m=t,n.c=e,n.d=function(t,e,o){n.o(t,e)||Object.defineProperty(t,e,{enumerable:!0,get:o})},n.r=function(t){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(t,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(t,"__esModule",{value:!0})},n.t=function(t,e){if(1&e&&(t=n(t)),8&e)return t;if(4&e&&"object"==typeof t&&t&&t.__esModule)return t;var o=Object.create(null);if(n.r(o),Object.defineProperty(o,"default",{enumerable:!0,value:t}),2&e&&"string"!=typeof t)for(var r in t)n.d(o,r,function(e){return t[e]}.bind(null,r));return o},n.n=function(t){var e=t&&t.__esModule?function(){return t.default}:function(){return t};return n.d(e,"a",e),e},n.o=function(t,e){return Object.prototype.hasOwnProperty.call(t,e)},n.p="/wp-content/themes/nexstar/client/build/",n(n.s=102)}({102:function(t,e,n){t.exports=n(103)},103:function(t,e,n){"use strict";n.r(e);var o=n(28);Object(o.a)(),googletag.cmd.push((function(){var t=function(t,e,n){var o;try{o=t.slot[e].apply(t.slot,n)}catch(t){o="[unknown]"}return o};googletag.pubads().addEventListener("slotRenderEnded",(function(e){if(e.slot){var n=e.slot,o=e.isEmpty,r=e.size,i=n.getSlotElementId(),a="AD SLOT RENDERED {\n  containerId: ".concat(i,",\n  isEmpty: ").concat(o,",\n  size: ").concat(r,",\n  adUnitPath: ").concat(t(e,"getAdUnitPath"),",\n  position: ").concat(t(e,"getTargeting",["pos"]),",\n}");if(window.setTimeout((function(){console.info(a)}),10),i.startsWith("acm-ad-tag-adhesion")&&!o){var c=document.getElementById(i).parentNode;c.classList.remove("pre-render"),c.querySelector(".close-btn-container").addEventListener("click",(function(t){t.preventDefault(),c.parentNode.remove()}),!1)}if(i.startsWith("acm-ad-tag-oop")&&!o&&document.body.classList.add("has-loaded-super-billboard-ad"),i&&!o&&r&&"function"==typeof document.getElementById(i).closest){var d=document.getElementById(i).closest(".ad-unit");if(d){var u=d.querySelector(".ad-unit__content > div[id^=acm]");if(u){var l=r[0],s=void 0===l?null:l,f=r[1],g=void 0===f?null:f;s&&g&&(u.setAttribute("width",s),u.setAttribute("height",g))}d.classList.add("ad-unit--is-rendered")}}}}))}))},28:function(t,e,n){"use strict";e.a=function(){window.googletag=window.googletag||{},window.googletag.cmd=googletag.cmd||[]}}});
//# sourceMappingURL=ad-handler.bundle.min.js.map</script><script>
var wpApiSettings = {"root":"https:\/\/www.rochesterfirst.com\/wp-json\/","nonce":"b1751efecf","versionString":"wp\/v2\/"};
</script>
<script src='https://www.rochesterfirst.com/wp-includes/js/api-request.min.js?ver=5.4.2'></script>
<script>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</script>
<script src='https://www.rochesterfirst.com/wp-content/themes/nexstar/client/build/js/global.bundle.min.js?ver=112b57b5c6fb5c33bf49'></script>
<script src='https://www.rochesterfirst.com/wp-content/themes/nexstar/client/build/js/article.bundle.min.js?ver=e1916b7c22122434057b'></script>
<script async src='https://s7.addthis.com/js/300/addthis_widget.js?ver=1.0.0#pubid=ra-5b7190c0239b8829'></script>
<script>
var addthis_config=addthis_config||{};addthis_config.data_track_addressbar=false;addthis_config.data_track_clickback=false;
var addthis_share = window.addthis_share || {"url":"https:\/\/www.rochesterfirst.com\/news\/politics\/careers-hang-on-mail-in-ballots-for-2-house-democrats\/"}
</script>
<script src='https://www.rochesterfirst.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202027.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'162794684',post:'464337',tz:'-4',srv:'www.rochesterfirst.com'} ]);
	_stq.push([ 'clickTrackerInit', '162794684', '464337' ]);
</script>

</body>
</html>
